Jump to content


Photo

Charset - Fail ¬¬


  • Faça o login para participar
4 replies to this topic

#1 AlessandroWeb

AlessandroWeb

    Turista

  • Usuários
  • 56 posts
  • Sexo:Masculino
  • Localidade:Suzano / SP

Posted 25/03/2010, 13:29

Vejam isso:

H� CENTENAS de anos o homem cria e altera ra�as de c�es. Embora o objetivo fosse desenvolver c�es mais bonitos, nem sempre a sa�de do bicho foi levada em conta. Esta � uma das conclus�es de um grupo [...]


Como posso resolver isso?
Esse texto veio do banco de dados do WordPress.

Qual charset usar?

atual = utf-8

VLW!!
Atenciosamente,
Alessandro Santos.
igloo Internet Solutions
www.igloointernet.net

#2 hostdesigner

hostdesigner

    Super Veterano

  • Usuários
  • 2910 posts
  • Sexo:Masculino
  • Localidade:Quirinópolis-GO
  • Interesses:Programação, Mulheres, Diversão, Mulheres, Música, Mulheres, Meu Carro, Mais mulheres, Internet, Outras Mulheres, Quase por último PAZ e por ultimo Outras Váááárias Mulheres...

Posted 25/03/2010, 18:21

@ ALESSANDROWEB
Você deve usar utf-8 no caso de o WordPress estar utilizando este encode para publicar conteúdo, também é necessário definir a conexão como utf-8, nem preciso dizer que a página também precisa estar em utf-8

Falopa!

#3 AlessandroWeb

AlessandroWeb

    Turista

  • Usuários
  • 56 posts
  • Sexo:Masculino
  • Localidade:Suzano / SP

Posted 26/03/2010, 09:39

@ ALESSANDROWEB
Você deve usar utf-8 no caso de o WordPress estar utilizando este encode para publicar conteúdo, também é necessário definir a conexão como utf-8, nem preciso dizer que a página também precisa estar em utf-8

Falopa!

Vlw por responder..

Mas acontece que minha página tá utf8
o wordpress (fiz down de uns files o olhei) tbm tah utf8

coloquei isso aqui na minha página:

mysql_set_charset('utf8');

mas continou do mesmo jeito os caracteres.
:huh:
Atenciosamente,
Alessandro Santos.
igloo Internet Solutions
www.igloointernet.net

#4 hostdesigner

hostdesigner

    Super Veterano

  • Usuários
  • 2910 posts
  • Sexo:Masculino
  • Localidade:Quirinópolis-GO
  • Interesses:Programação, Mulheres, Diversão, Mulheres, Música, Mulheres, Meu Carro, Mais mulheres, Internet, Outras Mulheres, Quase por último PAZ e por ultimo Outras Váááárias Mulheres...

Posted 26/03/2010, 10:25

@ ALESSANDROWEB
Você deve colocar mysql_set_charset junto com o mysql_connect, do contrário realmente não funciona. Verifica se os dados estão corrompidos dentro da base, se for isso não tem solução.

Falopa!

#5 AlessandroWeb

AlessandroWeb

    Turista

  • Usuários
  • 56 posts
  • Sexo:Masculino
  • Localidade:Suzano / SP

Posted 26/03/2010, 10:47

@ ALESSANDROWEB
Você deve colocar mysql_set_charset junto com o mysql_connect, do contrário realmente não funciona. Verifica se os dados estão corrompidos dentro da base, se for isso não tem solução.

Falopa!

VLW cara Funfou!!

Para os q têem essa duvida, a solução foi essa:

$con_blog = mysql_pconnect($hostname_con_blog, $username_con_blog, $password_con_blog) or trigger_error(mysql_error(),E_USER_ERROR); 
mysql_select_db($database_con_blog);
mysql_set_charset('utf8', $con_blog);

T+ VLW!!
Atenciosamente,
Alessandro Santos.
igloo Internet Solutions
www.igloointernet.net




0 user(s) are reading this topic

0 membro(s), 0 visitante(s) e 0 membros anônimo(s)

IPB Skin By Virteq