Jump to content


Photo

Avatar Aleatório Com Php


  • Faça o login para participar
91 replies to this topic

#61 Klaus

Klaus

    @ ubuntu jaunty

  • Ex-Admins
  • 7924 posts
  • Sexo:Masculino
  • Localidade:127.0.0.1

Posted 28/11/2004, 19:08

Se pasta termina em .png não precisa do .htaccess. Qual mensagem de erro que dá?
Klaus Paiva
Conheça também: Taperás

#62 KrEmEr

KrEmEr

    www.radiointeract.org

  • Usuários
  • 145 posts
  • Sexo:Não informado
  • Localidade:Cruzeiro - SP
  • Interesses:"Queria ser um baseado<br> Pra nascer em seus dedos,<br> Pra morrer em tua boca<br> E pra fazer tua cabeça."<br><br> (Bob Marley)

Posted 28/11/2004, 19:27

AI Klaus... eu sei la o q ta acontecendo aki... tipow...
antes tava dando erro... agora naum ta mais... eu consigui colocar os dois arq....
eu coloquei a pasta no servi como index.png ai depois dentro dela eu coloquei as fotos...
no mesmo diretorio dela eu coloquei o arquivo php... eh assim q tem q ser??/
o arq php ta com o codigo do tiago....
ah e qual arq q manda para o forum?? é a pasta né?!?!?!

abraços... t+....


:D :) :( :angry:
Ricardo Odorizi Olivas
Nick: -=| K®ëMë® |=-
Email: ricardoolivas@osite.com.br
Icq: 178211495
Msn: "Use o forum pra tirar dúvida."

#63 Klaus

Klaus

    @ ubuntu jaunty

  • Ex-Admins
  • 7924 posts
  • Sexo:Masculino
  • Localidade:127.0.0.1

Posted 28/11/2004, 19:32

Você diz para o fórum o endereço da pasta. Não vai enviar, vai indicar a URL.
Klaus Paiva
Conheça também: Taperás

#64 brunoXP

brunoXP

    EFEI EÔ

  • Conselheiros
  • 2226 posts
  • Sexo:Masculino
  • Localidade:Campinas/Itajubá

Posted 07/12/2004, 08:52

E como eu coloco os avatares no fórum?
Bruno Toffolo
· Conselho / WebFórum

#65 Klaus

Klaus

    @ ubuntu jaunty

  • Ex-Admins
  • 7924 posts
  • Sexo:Masculino
  • Localidade:127.0.0.1

Posted 07/12/2004, 11:09

Diz pro fórum a URL da sua pasta de avatares.
Klaus Paiva
Conheça também: Taperás

#66 Fábio

Fábio

    = )

  • Usuários
  • 547 posts
  • Sexo:Masculino
  • Localidade:Rio de Janeiro - RJ
  • Interesses:Aprender e, na medida do possível, ensinar.

Posted 20/12/2004, 05:22

Engraçado. Eu coloquei 7 imagens a serem redirecionadas, mas apenas as 4 primeiras estão aparecendo? O que está acontecendo?

Eu devo adicionar ou alterar alguma função?

E outra: Pra que serve a função $random = rand (0, 3); ????

----------------
EDITADO
Resolvido: Desculpem-me por não ter tentado antes, mas quando alterei de 0,3 para 0,7 funcionou, mas ficou com erro em uma imagem, depois alterei para 0,6, e ficou perfeito =]

[]s

Edição feita por: Fábio Gonçalves, 20/12/2004, 05:33.

Fábio Martinho
www.fabiomartinho.com
Participante da equipe de 11/11/2005 a 20/11/2007.

#67 sonyfero

sonyfero

    Novato no fórum

  • Usuários
  • 20 posts
  • Sexo:Não informado

Posted 21/12/2004, 11:07

Fabio,

Você está usando o primeiro código (que precisa por o nome das imagens)?

o rand vai sortear a imagem, mas conta a partir do 0

0, 1, 2, 3...

então se tem 7 imagens, tem q mandear sortear de 0 a 6

então coloca lá $random = rand(0, 6);

---

esse código do cristiano foi o que funcionou melhor, pois ele exibe as gifs animadas, com fundo transparente e tal.. ficou rox! :D

depois dele vem o do thiago, pq tbm nao precisa colocar o nome das imagens

---

aqui tá assim:
X/avatar/sony1.png/avatar/avatar.xxx (pasta com os avatares)
X/avatar/sony1.png/index.php (script do thiago)
X/avatar/sony2.png/index.php (script do cristiano)

mudei no script do cristiano:

$dir = './avatar/'; // Diretório das imagens
para
$dir = '../sony1.png/avatar/'; // Diretório das imagens


----

thiago, seu script não aceita "../avatar/" :(
parece que ele não acha a pasta, sabe me dizer porquê?

daí eu usava só "../avatar/" nos 2 scripts
colocando a pasta avatar "ao lado" das 2 .png

---

tava mexendo enquanto escrevia, tirei o resize do script do thiago
daí usei o imagepng e o image destroi direto da $im
agora funciona belezinha as minhas gifs :)

--- edit ---

sem o resize mostrou o fundo transparente + continua estatico..
tem solucao quanto a isso tambem, thiago?

--- edit 2 ---

o script do cristiano não é "a prova de firefox"
ele salva a img de modo que a imagem não é "puxada" de novo
pq ele "já tem a imagem" .png salva no cache... :(
dai quando navega ou aperta f5, nao randomiza

só altera se eu usar ctrl+F5..

Edição feita por: sonyfero, 21/12/2004, 11:21.


#68 sonyfero

sonyfero

    Novato no fórum

  • Usuários
  • 20 posts
  • Sexo:Não informado

Posted 21/12/2004, 14:33

GOSTEI DISSO!! :D

Como alguns fóruns tem limite de tamanho e tal, e varia muito de um pro outro, resolvi dar uma mexida, e saiu uma coisa legal :)

removido

-edit-

agora está no meu fórum. não tenho tempo de ficar vindo atualizar aqui...

endereço: http://forum.crashteam.net/index.php?showtopic=36

Edição feita por: sonyfero, 13/03/2005, 22:25.


#69 DTLucchesi

DTLucchesi

    O fim da picada é quando o mosquito vai embora!

  • Usuários
  • 202 posts
  • Sexo:Masculino
  • Localidade:São Paulo
  • Interesses:ASP

Posted 29/12/2004, 03:26

Nota 10...

Vc explicou muito bem como se faz, parabéns!

Edição feita por: DTLucchesi, 29/12/2004, 03:28.

ia assinar, mas esqueci a caneta!

#70 janainadorneles

janainadorneles

    Normal

  • Usuários
  • 116 posts
  • Sexo:Não informado

Posted 12/01/2005, 04:21

estava tentando fazer funcionar e não consigo depois de gerar a imagem busca informações do banco de dados... PQ?


<?php


include ("conectar.php");

$s = mysql_query("SELECT * FROM cliente WHERE id='287'");
$dados = mysql_fetch_array($s);

$foto = $dados["foto"];


$imagem = "$foto";
$im = imagecreatefromjpeg($imagem);
$largurao = imagesx($im);//
$alturao = imagesy($im);
$alturad = 60;
$largurad = ($largurao*$alturad)/$alturao;

$nova = imagecreatetruecolor($largurad,$alturad);
imagecopyresampled($nova,$im,0,0,0,0,$largurad,$alturad,$largurao,$alturao);
imagejpeg($nova);
imagedestroy($nova);
imagedestroy($im);


echo "<table>
<tr>

<td>$nome</td>
<td>$imagem</td>


</tr>
</table>



?>


Oque acontece que não busca, e sim ele da erro?
-- Janaina Dorneles
- Monitor Webdesign

· Navegador: FireFOX
· Sistem OS: Linux Conectiva
Esse é o melhor forum de PHP do Brasil :D

#71 Klaus

Klaus

    @ ubuntu jaunty

  • Ex-Admins
  • 7924 posts
  • Sexo:Masculino
  • Localidade:127.0.0.1

Posted 12/01/2005, 12:00

Você tá tentando imprimir a imagem direto junto com HTML???

Se for, gere a imagem, salvando-a (segundo parâmetro) do imagejpeg() e chame-a com <img />.
Klaus Paiva
Conheça também: Taperás

#72 R0x_Boy

R0x_Boy

    Novato no fórum

  • Usuários
  • 15 posts
  • Sexo:Não informado

Posted 19/02/2005, 03:00

Muito BOM MESMO

Melhor se Der para Linkar, Tipo á images/Imagem.jpg

ficar assim <a href="images/Imagem.jppg">

Dá?

pois naum vi eho e sou iniciante :D

#73 lula_molusco

lula_molusco

    Novato no fórum

  • Usuários
  • 3 posts
  • Sexo:Não informado

Posted 25/02/2005, 19:23

será que não funciona no msn messenger isso ai?

#74 _luiz

_luiz

    Novato no fórum

  • Usuários
  • 15 posts
  • Sexo:Não informado

Posted 27/02/2005, 01:36

Quando eu fui tentar aparecia a imagem com um x vermelho (de erro), eu acho que é por que eu não falei a extensão das minhas imagens (.gif).

As pastas estão localizadas assim:

- images  (pasta)
-- Peanuts1.gif  (arquivo)
-- Peanuts2.gif  (arquivo)
-- Peanuts3.gif  (arquivo)
- .htaccess.txt  (arquivo)
- index.php  (arquivo)

O que eu to errando? (E se for isso que eu acho, como eu arrumo?)

ps.: eu usei o script do Sonyfero.
"É impossível ir contra o sistema. Somos filhos dele."
Thiago Casimiro

#75 sonyfero

sonyfero

    Novato no fórum

  • Usuários
  • 20 posts
  • Sexo:Não informado

Posted 28/02/2005, 01:17

@_luiz,

renomeie a pasta para imageNs (ou mude o $dir para images)

e pode esquecer o htaccess, nao precisa!

Edição feita por: sonyfero, 28/02/2005, 01:18.





8 user(s) are reading this topic

0 membro(s), 8 visitante(s) e 0 membros anônimo(s)

IPB Skin By Virteq