Jump to content


Photo

[Resolvido] Problemas Com Apache


  • Faça o login para participar
21 replies to this topic

#1 rodrigolindoso

rodrigolindoso

    Novato no fórum

  • Usuários
  • 9 posts
  • Sexo:Masculino
  • Localidade:São Luís - MA

Posted 23/07/2010, 15:28

Bom pessoal, eu estou tendo um problema com servidores Apache / MySQL / PhpyAdmin enfim... Eu usava o VertrigoServ, funcionava perfeitamente, mais de uns dias pra cá ele simplesmente parou de funcionar. Eu ligo o Vertrigo e diz que está tudo certo, ou seja, Online, mais quando eu tento acessar a página local, diz que não existe ou o navegador não encontra mesmo tendo arquivos lá. Acontece o mesmo com os outros servidores que tentei como: EasyPHP, Xampp, Wamp ... Eu olhei um tópico aqui sobre que poderia ser o IIS, eu fiz o que o membro respondeu e deu a mesma coisa, que era trocar a porta de 80 para outra, fiz isso mais continuo do mesmo jeito. Eu tenho o Skype aqui, e sei que da interferência quando ele está aberto, mais ele não está aberto. O estranho disso tudo, é que o Skype está marcado para iniciar junto com o Windows, e ele não está mais iniciando com o Windows, mesmo com a opção lá no programa, marcada. Eu já tentei de tudo, não sei mais o que fazer, eu preciso resolver esse problema.

Meu sistema operacional é o Windows 7 Ultimate.

Preciso da ajuda de vocês urgente!

Atenciosamente, Rodrigo Lindoso.

#2 LeoB

LeoB

    Super Veterano

  • Usuários
  • 1876 posts
  • Sexo:Masculino
  • Interesses:Programação

Posted 23/07/2010, 16:37

Se você tem o IIS, porque não configura o PHP pra rodar nele? Ainda assim, se quiser usar o Apache, dê uma olhada na pasta de logs. Pode ter alguma mensagem lá esclarecendo o problema. Se não tiver nada, pare o IIS ou qualquer outro programa que você ache que possa estar ocupando a porta 80. Abra o prompt e digite:

netstat -a -b

E veja se alguém continua escutando nela.

#3 rodrigolindoso

rodrigolindoso

    Novato no fórum

  • Usuários
  • 9 posts
  • Sexo:Masculino
  • Localidade:São Luís - MA

Posted 24/07/2010, 11:52

O IIS do meu Computador ta desativado, me explique como faço pra mudar o apache pro IIS, eu vou poder usar o mesmo MySQL/PMA ?

#4 LeoB

LeoB

    Super Veterano

  • Usuários
  • 1876 posts
  • Sexo:Masculino
  • Interesses:Programação

Posted 24/07/2010, 11:58

Pode sim.

http://www.php.net/m...indows.iis7.php

Siga os passos com atenção e não tem erro.

#5 rodrigolindoso

rodrigolindoso

    Novato no fórum

  • Usuários
  • 9 posts
  • Sexo:Masculino
  • Localidade:São Luís - MA

Posted 24/07/2010, 12:39

Eu instalei o iis, e deu o mesmo problema, eu fui no gerenciamento e o processo dizia estar iniciado, mais eu não conseguia acessar http://localhost/ :S

Já removi Skype, já tirei os servidores apache, mais nada ta dando certo :S

#6 LeoB

LeoB

    Super Veterano

  • Usuários
  • 1876 posts
  • Sexo:Masculino
  • Interesses:Programação

Posted 24/07/2010, 13:52

Ah, é verdade. Windows 7. Tenta aí:

http://127.0.0.1

#7 rodrigolindoso

rodrigolindoso

    Novato no fórum

  • Usuários
  • 9 posts
  • Sexo:Masculino
  • Localidade:São Luís - MA

Posted 24/07/2010, 14:09

Já tentei os dois, http://localhost/ e http://127.0.0.1/ e não deu certo :s

#8 LeoB

LeoB

    Super Veterano

  • Usuários
  • 1876 posts
  • Sexo:Masculino
  • Interesses:Programação

Posted 24/07/2010, 14:33

Você usou o netstat como eu falei na primeira resposta?

#9 rodrigolindoso

rodrigolindoso

    Novato no fórum

  • Usuários
  • 9 posts
  • Sexo:Masculino
  • Localidade:São Luís - MA

Posted 24/07/2010, 15:15

Sim, aparece isso:

TCP<Tab>0.0.0.0:80<Tab>Lindoso:0<Tab>Listening


E o arquivo log de erro do Apache, aparece isso:

[Sat Jul 24 15:10:53 2010] [warn] pid file C:/Program Files/VertrigoServ/Apache/logs/httpd.pid overwritten -- Unclean shutdown of previous Apache run?
[Sat Jul 24 15:10:53 2010] [notice] Apache/2.0.63 (Win32) PHP/5.2.6 configured -- resuming normal operations
[Sat Jul 24 15:10:53 2010] [notice] Server built: Jan 17 2008 22:58:29
[Sat Jul 24 15:10:53 2010] [notice] Parent: Created child process 3964
[Sat Jul 24 15:10:53 2010] [notice] Child 3964: Child process is running
[Sat Jul 24 15:10:53 2010] [notice] Child 3964: Acquired the start mutex.
[Sat Jul 24 15:10:53 2010] [notice] Child 3964: Starting 250 worker threads.


Me ajude por favor!

#10 LeoB

LeoB

    Super Veterano

  • Usuários
  • 1876 posts
  • Sexo:Masculino
  • Interesses:Programação

Posted 24/07/2010, 15:45

É pra aparecer o nome do exe embaixo dessa linha aí do netstat. Veja qual é.

#11 rodrigolindoso

rodrigolindoso

    Novato no fórum

  • Usuários
  • 9 posts
  • Sexo:Masculino
  • Localidade:São Luís - MA

Posted 24/07/2010, 15:49

Não, não aparece nenhum nome de nenhum aplicativo, nem nas outras

#12 LeoB

LeoB

    Super Veterano

  • Usuários
  • 1876 posts
  • Sexo:Masculino
  • Interesses:Programação

Posted 24/07/2010, 16:00

Colocou o -a -b?

#13 rodrigolindoso

rodrigolindoso

    Novato no fórum

  • Usuários
  • 9 posts
  • Sexo:Masculino
  • Localidade:São Luís - MA

Posted 24/07/2010, 16:09

Sim

@edit

O v_apache que é o processo do vertrigo que inicia o apache ta usando a porta 135.

Olha a imagem:

Posted Image
-> http://j.imagehost.o...titled-1_11.jpg

OBS: se eu mudar a porta pra 135 lá no httpd.conf do apache, dá erro, erro como se já tivessem usando essa porta.
OBS²: Eu tentei acessar usando: http://127.0.0.1:135 ou http://localhost:135/ não funciono de nenhum jeito

Edição feita por: rodrigolindoso, 24/07/2010, 16:19.


#14 LeoB

LeoB

    Super Veterano

  • Usuários
  • 1876 posts
  • Sexo:Masculino
  • Interesses:Programação

Posted 24/07/2010, 16:34

Está usando a porta 80, na verdade. O nome do exe é da linha de cima. Abre o arquivo

C:\Windows\system32\drivers\etc\hosts

com o bloco de notas e mostra o que tem nele.

#15 rodrigolindoso

rodrigolindoso

    Novato no fórum

  • Usuários
  • 9 posts
  • Sexo:Masculino
  • Localidade:São Luís - MA

Posted 24/07/2010, 16:35

Tem isso:

127.0.0.1 localhost




2 user(s) are reading this topic

0 membro(s), 2 visitante(s) e 0 membros anônimo(s)

IPB Skin By Virteq