Jump to content


Photo

Utilizar Porcentagem Em Objeto Flash


  • Faça o login para participar
15 replies to this topic

#1 Bomba Net

Bomba Net

    12 Horas

  • Usuários
  • 205 posts
  • Sexo:Masculino
  • Localidade:São José dos Campos
  • Interesses:me intereso em atuar nas areas de webdesingner e de webdeveloper

Posted 04/08/2008, 08:55

Olá...


Estou tentando tabalhar com porcentagem no flash, para que independente da resolução, o flash ocupe 100% da largura da div.

No inhternet Explorer funciona certinho, só que o firefox não funciona o flash fica um quadrado minusculo no canto da div.

Tem algum tratamento especial para a porcentagem funcionar tambem no firefox?
Everton Lima
WebMaster

www.iMessenger.com.br

#2 Bomba Net

Bomba Net

    12 Horas

  • Usuários
  • 205 posts
  • Sexo:Masculino
  • Localidade:São José dos Campos
  • Interesses:me intereso em atuar nas areas de webdesingner e de webdeveloper

Posted 12/08/2008, 08:52

tentei alguns códigos que achei na internet mas não funcionou...

é impossível utilizar porcentagem no firefox? ele não aceita está propriedade?
Everton Lima
WebMaster

www.iMessenger.com.br

#3 '' sem.Ponto

'' sem.Ponto

    Super Veterano

  • Ex-Admins
  • 2098 posts
  • Sexo:Masculino
  • Localidade:Belo Horizonte

Posted 12/08/2008, 23:18

Impossível não é não. ;)

Cadê a página pra gente ver?
att,
Muller Dias
ex-administrador Fórum WMO

#4 Bomba Net

Bomba Net

    12 Horas

  • Usuários
  • 205 posts
  • Sexo:Masculino
  • Localidade:São José dos Campos
  • Interesses:me intereso em atuar nas areas de webdesingner e de webdeveloper

Posted 13/08/2008, 14:15

http://www.byhenri.com.br/teste/
Everton Lima
WebMaster

www.iMessenger.com.br

#5 '' sem.Ponto

'' sem.Ponto

    Super Veterano

  • Ex-Admins
  • 2098 posts
  • Sexo:Masculino
  • Localidade:Belo Horizonte

Posted 13/08/2008, 18:57

Parece que a causa do problema é o display: table-cell na div #conteudo, tenta mudar para block. ;)

Mas uma boa dica que eu lhe dou é sempre colocar width e height em todos os elementos quando você for trabalhar só com porcentagem, todas as divs e até mesmo no html e body, assim você evitará problemas. ^_^
att,
Muller Dias
ex-administrador Fórum WMO

#6 Bomba Net

Bomba Net

    12 Horas

  • Usuários
  • 205 posts
  • Sexo:Masculino
  • Localidade:São José dos Campos
  • Interesses:me intereso em atuar nas areas de webdesingner e de webdeveloper

Posted 19/08/2008, 10:05

Bom agora não ficou tão esprimido no canto...

Como devo utilizar tamanho se eu quero deixar que a div fique com porcentagem tambem? eu definir altura e largura da div com porcentagem vale essa sua dica?


To usando 100% no height mas nao adianta no firefox, tem diferneça do 100% pro auto?

---

parece que a largura ta 100%
porem a largura não... já tentei colocar height:100% e position Relative., nmas nao adianta =/

Edição feita por: Bomba Net, 19/08/2008, 11:05.

Everton Lima
WebMaster

www.iMessenger.com.br

#7 Bomba Net

Bomba Net

    12 Horas

  • Usuários
  • 205 posts
  • Sexo:Masculino
  • Localidade:São José dos Campos
  • Interesses:me intereso em atuar nas areas de webdesingner e de webdeveloper

Posted 25/08/2008, 09:17

vejam

http://www.byhenri.com.br
no IE ta sussa, já no firefox ficou pequeno a altura, estranho que a largura ta 100%

tem algum hack pra ff?
Everton Lima
WebMaster

www.iMessenger.com.br

#8 Alex Hiroshi

Alex Hiroshi

    Super Veterano

  • Ex-Admins
  • 4923 posts
  • Sexo:Masculino
  • Localidade:São Paulo - SP

Posted 27/08/2008, 07:57

Tire o height:auto !important; /* Para browsera modernos */ do #tudo e coloque height:100% no #topo.
Fórum WMO - Equipe de Desenvolvimento / Banco de Dados - Ex-Administrador

#9 Bomba Net

Bomba Net

    12 Horas

  • Usuários
  • 205 posts
  • Sexo:Masculino
  • Localidade:São José dos Campos
  • Interesses:me intereso em atuar nas areas de webdesingner e de webdeveloper

Posted 27/08/2008, 09:54

Alex,
Muito obrigado por responder!

fiz como você disse, porém não mudou nada aparentemente.
Everton Lima
WebMaster

www.iMessenger.com.br

#10 Alex Hiroshi

Alex Hiroshi

    Super Veterano

  • Ex-Admins
  • 4923 posts
  • Sexo:Masculino
  • Localidade:São Paulo - SP

Posted 27/08/2008, 10:35

Você testou no seu computador? Não vi a mudança no servidor.
Verifique também se todas as divs onde o embed está, estão com height 100%. Em algumas divs você está usando height auto e 100%, mas com um important no auto, isso vai fazer com que o navegador pegue só o auto, não o 100%.
Fórum WMO - Equipe de Desenvolvimento / Banco de Dados - Ex-Administrador

#11 Bomba Net

Bomba Net

    12 Horas

  • Usuários
  • 205 posts
  • Sexo:Masculino
  • Localidade:São José dos Campos
  • Interesses:me intereso em atuar nas areas de webdesingner e de webdeveloper

Posted 27/08/2008, 10:53

Eu Mandei pro servidor e testei, mais a mudança deixou outras paginas zuadas.
o topo ficou do tamanho da tela e só depois aparecia o conteúdo (em paginas que nao utilizam o flash)


Esse important eu peguei de algum tutorial na internet, já tentie tudo que eu achei no google e nada.

Todas as Divs estão com 100% no height,veja:


#tudo {
text-align: center;
width: 100%;
position:relative;
min-height:100%; /* Para browsera modernos */
height:auto !important; /* Para browsera modernos */
height:100%; /* Para o IE6 */


#conteudo{
background-image: url(layout/fundoMeio.jpg);
text-align: center;
min-height:85%;
height:auto;
/*height:84%; */
width: 100%;
position: relative;
padding: 0px;
margin: 0 auto;
padding-bottom:10px; /* Esse padding é o mesmo valor da altura do rodapé */


Tem algum material falando sobre esse "important" ? existem outras funções n ocss pra dar preferencia e talz? desconhecia.

--
já tirei o important e mandei pro servidor

Edição feita por: Bomba Net, 27/08/2008, 10:57.

Everton Lima
WebMaster

www.iMessenger.com.br

#12 Alex Hiroshi

Alex Hiroshi

    Super Veterano

  • Ex-Admins
  • 4923 posts
  • Sexo:Masculino
  • Localidade:São Paulo - SP

Posted 27/08/2008, 11:06

O problema está nesse topo. O seu html está estranho, todo o seu conteúdo fica dentro do topo, por isso não dá certo o height 100% e quando dá, estraga outras coisas por causa desse topo. Deixe o topo só para o topo, nada mais.

O importante é para dar prioridade a propriedade. Por exemplo, se você colocar height: 4px !important; height: 100px;, o de quatro pixel será usado, e não o cem, mesmo estando por último. Ou seja, o efeito cascata não funcionaria.
http://www.maujor.co...-com-important/
Fórum WMO - Equipe de Desenvolvimento / Banco de Dados - Ex-Administrador

#13 Bomba Net

Bomba Net

    12 Horas

  • Usuários
  • 205 posts
  • Sexo:Masculino
  • Localidade:São José dos Campos
  • Interesses:me intereso em atuar nas areas de webdesingner e de webdeveloper

Posted 27/08/2008, 11:26

Agora que eu tinha visto o ngócio do topo, muito estranho, deve ter sido algum erro meu ou da pessoa uqe montou o layout.

Arrumei ele, olhe como está a estrutura do layout, pois o height continua sem funcionar 100% no FF, mas no IE ta perfeito... e no firefox percebi que o width funciona 100% problema é só com o height

<head>
<link href="estilo.css" rel="stylesheet" type="text/css" />
<link href="menu.css" rel="stylesheet" type="text/css" />


</head>

<body>

<div id="tudo">
<div id="topo">
<div id="logo">
FLASH DO LOGO
</div></div>código menu
<div style="clear: left" />
</div>

<div id="conteudo">
<object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://fpdownload.ma...ersion=8,0,0,0" name="fotos" width="100%" height="100%" align="middle" id="fotos">
<param name="allowScriptAccess" value="sameDomain" />
<param name="movie" value="fotos.swf" />
<param name="quality" value="high" />
<param name="menu" value="false" />
<param name="wmode" value="transparent" />
<embed wmode="transparent" src="fotos.swf" quality="high" menu="false" width="100%" height="99%" name="fotos" align="middle" allowscriptaccess="sameDomain" type="application/x-shockwave-flash" pluginspage="http://www.macromedi...getflashplayer" />
</object>
</div>
<div id="clear"></div>
<div class="style4" id="rodape">ByHenri - Todos os Direitos reservados.</div>
</div>

</body>
</html>


Everton Lima
WebMaster

www.iMessenger.com.br

#14 Alex Hiroshi

Alex Hiroshi

    Super Veterano

  • Ex-Admins
  • 4923 posts
  • Sexo:Masculino
  • Localidade:São Paulo - SP

Posted 27/08/2008, 18:56

E o height no #conteudo? Toda div que estive 'cobrindo' o o embed, tem que estar com height 100%. O width funciona porque a div é um bloco e isso faz com que ele ocupe 100%, agora o height vai depender das divs estarem com 100%.
Fórum WMO - Equipe de Desenvolvimento / Banco de Dados - Ex-Administrador

#15 Bomba Net

Bomba Net

    12 Horas

  • Usuários
  • 205 posts
  • Sexo:Masculino
  • Localidade:São José dos Campos
  • Interesses:me intereso em atuar nas areas de webdesingner e de webdeveloper

Posted 29/08/2008, 09:14

Na div conteudo o height estava como auto.
ai tinha o min-height: 85%.. mudei o height pra 85% tbm e funcionou...

Valeu!

O problema que funcionou só na index, em outras paginas não, e a estreutura é a mesma=/
http://www.byhenri.c...santoandre.html

Abraços
Everton Lima
WebMaster

www.iMessenger.com.br




0 user(s) are reading this topic

0 membro(s), 0 visitante(s) e 0 membros anônimo(s)

IPB Skin By Virteq