Jump to content


Photo

Ajudinha - Algoritmo


  • Faça o login para participar
7 replies to this topic

#1 clansman

clansman

    Novato no fórum

  • Usuários
  • 2 posts
  • Sexo:Não informado

Posted 20/06/2008, 19:44

1) Escrever um algoritmo que leia um conjunto de 50 informações contendo, cada uma delas, a altura e o sexo de uma pessoa ( codigo =1 para masculino, codigo=2 para feminino),calcule e mostre o seguinte:

- a maior e a menor altura da turma
- a média da altura das mulheres
- a média da altura da turma

-------------------

algoritmo "Exercício_2"
// Função :
// Autor :
// Data : 20/6/2008
// Seção de Declarações
var
Maior_Altura, Menor_Altura, Med_Alt_Mulheres, Med_Alt_Turma, Altura : inteiro
Sexo_M_1, Sexo_F_2, Sexo, Cont : inteiro

inicio
// Seção de Comandos
LEIA (Altura)
Maior_Altura <- Altura
Menor_Altura <- Altura
Med_Alt_Mulheres <- 0
Med_Alt_Turma <- 0
		 PARA Cont DE 1 ATE 49 FACA
			  REPITA
					ESCREVAL ("Digite o Código do Sexo, Sendo 1 MASCULINO e 2 FEMININO : ")
					LEIA (Sexo)
			  ATE (Sexo=1) OU (Sexo=2)
			  Sexo_M_1 <- Sexo
			  Sexo_F_2 <- Sexo
			  ESCREVAL ("Digite a Altura : ")
			  LEIA (Altura)
			  SE Altura > Maior_Altura ENTAO
				 Maior_Altura <- Altura
			  FIMSE
			  SE Altura < Menor_Altura ENTAO
				 Menor_Altura <- Altura
			  FIMSE
			  ESCREVAL ("Menor Altura é = ", Menor_Altura)
			  ESCREVAL ("Maior Altura é = ", Maior_Altura)
			  ESCREVAL ("Media Altura Mulheres é = ", Med_Alt_Mulheres)
			  ESCREVAL ("Menor Altura Turma	é = ", Med_Alt_Turma <- )
		 FIMPARA
fimalgoritmo

nao estou conseguindo tirar as medias... alguem da um helps ae... flw !!

#2 dgt

dgt

    diego^SCFC

  • Usuários
  • 281 posts
  • Sexo:Masculino
  • Localidade:Recife-PE
  • Interesses:Java, Delphi, PHP, SQL, Modelagem de Dados, CSS, Lógica de Programação (Algoritmos), Teoria em Banco de Dados

Posted 21/06/2008, 04:16

Hmm.. vamos lá.

1. O LEIA(Altura) fora do laço é totalmente desnecessário.. você poderia fazer assim:
Maior_Altura <- 0
Menor_Altura <- 999
2. Se são 50 informações, o Para devia ser de 1 até 50.. ou de 0 a 49. E para testar você deveria colocar de 1 ate 3 ou ate 5.. Se funciona com 3 ou 5, funciona com 50, 100, 500..

3. Para calcular a média da altura de mulheres e da turma, você deve criar duas variáveis que armazene a altura de ambos e contar quantas pessoas é da categoria.
QtdTurma <- QtdTurma + 1
TotalAltura <- TotalAltura + Altura
Se (Sexo = 2) Entao
TotalMulheresAltura <- TotalMulheresAltura + Altura // Acumula altura das mulheres
QtdMulheres <- QtdMulheres + 1 // Acumula +1 mulher
FimSe
4. Para imprimir as médias, você tem que colocar os ESCREVAL fora do laço, se não a cada execução ele vai exibi-los.

5. Prestar atenção na definição das variáveis. Altura é do tipo real: 1,80... 1,70..

Código:
algoritmo "Exercício_2"
var
   Sexo, Cont, Qtd_Turma, Qtd_Mulheres: inteiro
   Altura, Maior_Altura, Menor_Altura, Total_Altura_Mulheres, Total_Altura: real
inicio
// Seção de Comandos
   Maior_Altura <- 0
   Menor_Altura <- 999
   Total_Altura <- 0
   Total_Altura_Mulheres <- 0
   Qtd_Mulheres <- 0
   Qtd_Turma <- 0
				 PARA Cont DE 1 ATE 3 FACA
					  REPITA
							ESCREVAL ("Digite o Código do Sexo, Sendo 1 MASCULINO e 2 FEMININO : ")
							LEIA (Sexo)
					  ATE (Sexo=1) OU (Sexo=2)
					  ESCREVAL ("Digite a Altura : ")
					  LEIA (Altura)
					  Qtd_Turma <- Qtd_Turma + 1
					  Total_Altura <- Total_Altura + Altura
					  Se (Sexo = 2) Entao
						  Total_Altura_Mulheres <- Total_Altura_Mulheres + Altura // Acumula altura das mulheres
						  Qtd_Mulheres <- Qtd_Mulheres + 1 // Acumula +1 mulher
					  FimSe
					  SE Altura > Maior_Altura ENTAO
						 Maior_Altura <- Altura
					  FIMSE
					  SE Altura < Menor_Altura ENTAO
						 Menor_Altura <- Altura
					  FIMSE
				 FIMPARA
   ESCREVAL ("Menor Altura é = ", Menor_Altura)
   ESCREVAL ("Maior Altura é = ", Maior_Altura)
   ESCREVAL ("Media Altura Mulheres é = ", Total_Altura_Mulheres / Qtd_Mulheres)
   ESCREVAL ("Média Altura Turma	é = ", Total_Altura / Qtd_Turma)
fimalgoritmo

Edição feita por: dgt, 21/06/2008, 04:24.

Posted Image

#3 clansman

clansman

    Novato no fórum

  • Usuários
  • 2 posts
  • Sexo:Não informado

Posted 21/06/2008, 18:38

Show de bola !

Obrigado !!!

#4 LarPhozyHah

LarPhozyHah

    Super Veterano

  • Usuários
  • 14515 posts
  • Sexo:Masculino
  • Localidade:San Miguel de Tucuman

Posted 23/10/2017, 14:24

Propecia Libido Impotence cheap cialis Buy Cialis Overnight Delivery Macrobid No Prior Script Propecia Para Alopecia
Levitra Modo D'Uso Viagra Adolescentes Fluoxetine Next Day Overseas No Prior Script viagra Amoxicillin Resistant Baclofene Belgique
Homemade Propecia Is Amoxicillin A Penicillin The Same viagra Cialis 20mg Info Discount Tadalafil Tablets
Buy Cheap Accutane Online No Prescription viagra Buy Viagra In Person Acheter Orlistat 120mg

#5 Miguceamma

Miguceamma

    MiguPenjisse

  • Usuários
  • 11724 posts

Posted 26/10/2017, 20:51

Cialis Kamagra Bestellen viagra Generic Viagra Reviews Message Board Where To Buy Beta Blockers
Medrol Dose Pack No Prescription buy levitra 10 mg Nebenwirkungen Von Viagra 100mg Viagra Online Italia
Vendita Cialis Generico Propecia Como Hacer viagra Kamagra Oral Acheter Cialis Buy Online Cheap Propecia Cost

#6 Miguceamma

Miguceamma

    MiguPenjisse

  • Usuários
  • 11724 posts

Posted 30/10/2017, 22:08

Cialis Achat Sur viagra online Xm Radio Generic Cialis Buy Furosemide Online Viagra E Cialis Problemi
Over The Counter Sex Pills In Canada Sildenafil 100mg 30 Pills levitra paypal accepted Cialis Vendo Propecia Male Breast Cancer

#7 LarPhozyHah

LarPhozyHah

    Super Veterano

  • Usuários
  • 14515 posts
  • Sexo:Masculino
  • Localidade:San Miguel de Tucuman

Posted 31/10/2017, 10:49

Viagra Quick Prescription Overnight Shipping On Cialis Cytotec En Venta who has the cheapest levitra Celecoxib Discount Indian Buy Accutane Online Legit

#8 LarPhozyHah

LarPhozyHah

    Super Veterano

  • Usuários
  • 14515 posts
  • Sexo:Masculino
  • Localidade:San Miguel de Tucuman

Posted 20/11/2017, 15:04

Amoxicillin 21 Propecia Generique 50mg Doxine Without Prescription Canada cialis Viagra Pharmacie Forum Evitra En Ligne Azithromycin Cost 500mg China
Over The Counter Prednisone At Walmart over seas orders for vardenafil Gel Viagra Viagra Dapoxetine Online Purchase 259 Propecia Klachten




0 user(s) are reading this topic

0 membro(s), 0 visitante(s) e 0 membros anônimo(s)

IPB Skin By Virteq