Jump to content


Photo

Link Entre Exe


  • Faça o login para participar
11 replies to this topic

#1 tmlnanet

tmlnanet

    Normal

  • Usuários
  • 77 posts
  • Sexo:Não informado

Posted 10/02/2005, 15:39

olá amigos, criei uma apresentação em flash para distrivuição em cd...acontece q para ter o autorun precisei transformar os arquivos em EXE....só q agora os arquivos não linkam....já tentei transformar todos os swf em exe e tb só transformar o 1º swf em exe....mas mesmo assim não linka....alguém sabe um jeito de resover isso??...desde já obrigado
"No fim tudo acaba bem, se não está bem, é porque não chegou ao fim"

#2 quarantines

quarantines

    idi Development Institute

  • Usuários
  • 318 posts
  • Sexo:Masculino
  • Localidade:Santa Cruz Cabrália - Costa do Descobrimento - Bahia
  • Interesses:Design, ActionScript, ASP, Flash, XML, Fireworks, Photoshop, Fotografia, Feijão com Arroz e ovo frito, Escrituras, Ajudar pessoas

Posted 10/02/2005, 15:42

Desculpa... explica de novo cara... vc criou uma apresentação pra cd... certo??

e q links são esses?? são swf's externos??

dica: utilize o botão editar, ok??

Abraços,

iDI

#3 tmlnanet

tmlnanet

    Normal

  • Usuários
  • 77 posts
  • Sexo:Não informado

Posted 10/02/2005, 16:02

sim...são swf externos, quando os arquivos estão todos em swf eles linkam normalmente, mas quando transformo em EXE eles perdem o link.
"No fim tudo acaba bem, se não está bem, é porque não chegou ao fim"

#4 Saruman

Saruman

    Veterano

  • Usuários
  • 1112 posts
  • Sexo:Masculino
  • Localidade:São Paulo, SP

Posted 10/02/2005, 16:14

Sim... o flash naum importa EXE... entaum tranforme apenas o primeiro em EXE ( o que vai ser iniciado pelo autorun ) e o resto permanece .swf
import Profile;

var saruman:Profile = new Profile();

saruman.nome = new String("Tiago S. Kaneta");

saruman.localizacao = new Array("São Paulo","SP");

#5 tmlnanet

tmlnanet

    Normal

  • Usuários
  • 77 posts
  • Sexo:Não informado

Posted 10/02/2005, 17:02

Saruman fiz isso q vc disse só q naum deu certo...depois q o filme do executavel termina e tem o link para o swf ( loadMovie("principal.swf",0) ) o executavel não carrega o filme "principal" e a tela fica parada...sem nada acontecer...
"No fim tudo acaba bem, se não está bem, é porque não chegou ao fim"

#6 ladybug

ladybug

    12 Horas

  • Usuários
  • 122 posts
  • Sexo:Não informado
  • Localidade:Rio de Janeiro

Posted 05/10/2005, 10:36

Olá amigos!

Também estou com o mesmo problema... Quando exporto em .exe ele para de chamar swfs e jpgs externos.

Já tentei de tudo que sei, mas não sei muito, entaum... Peço a ajuda dos que sabem mais!!!

Grande abraço!
Para ser grande, sê inteiro. Nada em ti exagere ou exclua. F. Pessoa

#7 CrAsh_OveRride

CrAsh_OveRride

    [Morbidamente curioso]

  • Usuários
  • 790 posts
  • Sexo:Masculino
  • Localidade:Viçosa

Posted 05/10/2005, 16:06

O mesmo problema meu!!!

No flash 7 eru fazia exatamente isso

1 exe principal quie chamava todos os outros swfs pelo comando:
loadMovieNum("arquivos.swf",0);


E funcioanva perfeito..

Agora que instalei o flash 8 nada funciona!!!!!

Alguem tem alguma ideia do que pode ser???


[]'s
←←←←←←←←←←←←←←←←←←←←←←←←←←←←←←
"Não sabendo que era impossível, foi lá e fez!"
←←←←←←←←←←←←←←←←←←←←←←←←←←←←←←

#8 ladybug

ladybug

    12 Horas

  • Usuários
  • 122 posts
  • Sexo:Não informado
  • Localidade:Rio de Janeiro

Posted 06/10/2005, 13:49

Seria possível, ao invés do exe chamar um swf, ele chamar outro exe??? Eu teria que mudar o código?
Para ser grande, sê inteiro. Nada em ti exagere ou exclua. F. Pessoa

#9 Foxn

Foxn

    Alone in the dark

  • Usuários
  • 1230 posts
  • Sexo:Masculino
  • Localidade:São Paulo - SP
  • Interesses:Programação, FLASH, JAVA SCRIPT, HTML, DHTML, XML, PHP e DELPHI

Posted 06/10/2005, 17:58

Saruman fiz isso q vc disse só q naum deu certo...depois q o filme do executavel termina e tem o link para o swf ( loadMovie("principal.swf",0) ) o executavel não carrega o filme "principal" e a tela fica parada...sem nada acontecer...

Correto: loadMovieNum("principal.swf",0)

[]'s
<?php $Nome = "Renato B. Pacheco";

	$Ocupacao = "Programador PHP";

	$Ocupacao .= "<br /> Programador ASP";

	$Ocupacao .= "<br /> Programador Action Script";

	$Localizacao =  "São Paulo - SP - Brasil" ?>

#10 ladybug

ladybug

    12 Horas

  • Usuários
  • 122 posts
  • Sexo:Não informado
  • Localidade:Rio de Janeiro

Posted 07/10/2005, 10:55

Oi pessoal! :)

Eu já tentei esse código e também não funcionou! Estou achando que é por ser flash 8, deve ter algum erro...

Bom, se alguém tiver alguma solução pro problema, posta aí!!!

Grande beijo!
(y)
Para ser grande, sê inteiro. Nada em ti exagere ou exclua. F. Pessoa

#11 ladybug

ladybug

    12 Horas

  • Usuários
  • 122 posts
  • Sexo:Não informado
  • Localidade:Rio de Janeiro

Posted 07/10/2005, 11:07

Oi galera... acabo de fazer o teste final... realmente no flash 8 tá dando pau, não funciona mesmo o exe fazer loadMovie externo, mas salvando como MX2004 (abrindo pelo MX2004 e exportando o exe por ele, e não pelo 8) funciona perfeitamente... a parte ruim é que não dá pra usar os efeitos novos que o flash 8 tem... pra quem quer um exe, tem que ficar limitado aos efeitos do MX2004.

Bom galera... é isso aí... se alguém souber como reverter essa situação, fala aí pra gente!

Beijocas!
Para ser grande, sê inteiro. Nada em ti exagere ou exclua. F. Pessoa

#12 CrAsh_OveRride

CrAsh_OveRride

    [Morbidamente curioso]

  • Usuários
  • 790 posts
  • Sexo:Masculino
  • Localidade:Viçosa

Posted 11/10/2005, 19:38

Eu também testei aqui e nada.

Li no manual sobre a função loadMovieNum, se houve alguma alteração e também não achei nada.
Realmente não queria voltar ao MX2004.

Alguém ae tem alguma idéia do que aconteceu? Será que é bug do 8?

[]'s
←←←←←←←←←←←←←←←←←←←←←←←←←←←←←←
"Não sabendo que era impossível, foi lá e fez!"
←←←←←←←←←←←←←←←←←←←←←←←←←←←←←←




0 user(s) are reading this topic

0 membro(s), 0 visitante(s) e 0 membros anônimo(s)

IPB Skin By Virteq